Problème de changement de page suite avis de MAJ ???

Mode d'emploi du forum et de l'album photos. Discussion sur la présentation et le contenu du site Lacaravane.com

Modérateurs : Modérateurs, Adhérent et modérateur

Répondre
Bonaud

Problème de changement de page suite avis de MAJ ???

Message par Bonaud » 24 mars 2009 17:28

Bonjour,

Lorsque je suis déjà connecté au forum, mais que je clique sur un lien reçu de mise à jour d'un Topic, donc pour un changement de page, il m'est systématiquement redemandé mon loggin et mon mot de passe alors que si je change de page moi-même pas de problème ???

Il suffit que je le mette, et le mot de passe se mets automatiquement, mais à la longue c'est désagréable...

Je précise que les cookies concernant le site sont sauvegardées (dans Ccleaner) et pas nettoyées lors du vidage régulier des cookies....
Je vais sur d'autres forums PHP, et leurs cookies sont aussi sauvegardées, et je n'y ai pas ce problème !
Ce serait donc spécifique au serveur....

Les cookies du site sont-ils à durée limitée ?

D'autres ont-ils aussi ce genre de problème ?

Merci de vos avis...

Serge
(XP Home SP2, IE6...)

Avatar de l’utilisateur
viscarien
Messages : 3014
Inscription : 11 juil. 2007 02:15
Localisation : FRANCE Plaine des VOSGES

Re: Problème de changement de page suite avis de MAJ ???

Message par viscarien » 25 mars 2009 00:43

Bonjour,

Pour commencer tu vas (dans IE)dans "outils" puis "options internet" puis "confidentialité" et cliques sur "avancé'.
Là tu as la gestion des cookies.Tu coches les cases désirées si besoin.(normalement aucune case n'est cochée et ça doit fonctionner)
Quand tu es dans "confidentialité" vérifie que le curseur de blocage est bien en position moyenne.Essaye aussi en position basse.
Si tu as programmé un nettoyage automatique suspends le pour essayer sans.
C'est tout ce que je vois pour l'instant.
CDLT.
Caravane Rapido,cuisine sortante
Porte-vélos Omnibike
Omnistore 2000
Auvent Clairval+abri cuisine(vestiaire).
Stab Tunesi 630. lames composite.
Mover Reich Éco.

Bonaud

Re: Problème de changement de page suite avis de MAJ ???

Message par Bonaud » 25 mars 2009 10:19

Bonjour,

@ viscarien

Comme déjà expliqué, les cookies du site ne sont pas "nettoyées", ni vidées à intervalle régulier, justement Ccleaner possède une fonction pour les sauvegarder, et je n'ai pas ce problème sur les autres forums PHP que je fréquente et dont les cookies sont sauvegardées de la même façon...

Néanmoins merci de ton essai d'aide, mais "tout" ça je connais...

Le problème est que cela semble spécifique au forum www.lacaravane.com puisque sur les autres forums PHP cela ne se produit pas...

Serge

Avatar de l’utilisateur
viscarien
Messages : 3014
Inscription : 11 juil. 2007 02:15
Localisation : FRANCE Plaine des VOSGES

Re: Problème de changement de page suite avis de MAJ ???

Message par viscarien » 25 mars 2009 14:08

C'est un drôle de "truc".Je ne vois pas ce que c'est.
Caravane Rapido,cuisine sortante
Porte-vélos Omnibike
Omnistore 2000
Auvent Clairval+abri cuisine(vestiaire).
Stab Tunesi 630. lames composite.
Mover Reich Éco.

Avatar de l’utilisateur
eden-speciale-540
Messages : 1302
Inscription : 22 mars 2009 23:25
Localisation : 2A - France

Re: Problème de changement de page suite avis de MAJ ???

Message par eden-speciale-540 » 25 mars 2009 14:24

bonjour

il semble effectivement y avoir un problème sur les sessions ( assez classique sous phpbb ), de plus le 'sid' est présent dans les urls ce qui n'est pas bénéfique du tout
d'ailleurs si vous activiez l'url rewriting sur ce forum, il serait mieux référencé, j'ai mis bien longtemps à le trouver ce forum :(, c'est regrettable
Image
- Hobby 560 Cfe 2011 1750 kg avec ETS, Clim, Truma SER, JA, ...
- Mitsubishi Pajero 3.5 L V6 24S essence un peu modifié :) Caravanier au long cours
- ex Caravelair Eden Special 540 2009

Bonaud

Re: Problème de changement de page suite avis de MAJ ???

Message par Bonaud » 04 avr. 2009 12:01

Bonjour,

Personne n'a une idée de la cause ???

Merci d'avance !

Serge

Avatar de l’utilisateur
freteurr
Modérateur
Messages : 32956
Inscription : 10 avr. 2005 12:46
Pays : France
Localisation : 78
Contact :

Re: Problème de changement de page suite avis de MAJ ???

Message par freteurr » 04 avr. 2009 12:07

Bonjour,

J'ai aussi le même problème seulement quand je passe avec internet explorer.
Je ne sais pas si ça le fait avec Mozilla Firefox.
Bonjour,
ImageImage
Au revoir

Avatar de l’utilisateur
hobby540
Messages : 6103
Inscription : 16 juin 2007 11:41
Pays : France
Localisation : Nice - FRANCE

Re: Problème de changement de page suite avis de MAJ ???

Message par hobby540 » 04 avr. 2009 12:13

Ca m'arrive aussi sous firefox, de temps en temps.

Je pense que c'est lorsqu'Olivier fait une modification sur le site ??
Image

Bonaud

Re: Problème de changement de page suite avis de MAJ ???

Message par Bonaud » 04 avr. 2009 12:47

hobby540 a écrit :Ca m'arrive aussi sous firefox, de temps en temps.
Je pense que c'est lorsqu'Olivier fait une modification sur le site ??
Ce serait souvent alors, et en semaine aussi dans la journée.... :D

J'ai quelques doutes....

Serge

Avatar de l’utilisateur
Olivier Pottier
Administrateur - Webmaster
Administrateur - Webmaster
Messages : 9319
Inscription : 23 oct. 2002 00:36
Pays : France
Localisation : Nantes (44)
Contact :

Re: Problème de changement de page suite avis de MAJ ???

Message par Olivier Pottier » 04 avr. 2009 18:48

Bonjour,

Je ne vois pas d'où viens ce problème.
Je n'ai pas effectué de modification sur le forum depuis plusieurs jours.

Le seul conseil que je puisse te donner est d'installer IE7 à la place de IE6
:arrow: http://www.01net.com/telecharger/window ... 33081.html
Cela résoudra peut-être ton problème....

A bientôt :)
Webmaster du site Lacaravane.com
Citroen C5 2.0HDI 138ch de 2006 + caravane Tabbert Comtesse 450 de 1996
Image

Bonaud

Re: Problème de changement de page suite avis de MAJ ???

Message par Bonaud » 04 avr. 2009 19:06

Effectivement ça pourrait le résoudre....

Mais je n'y tiens vraiment pas, il me mets le "bazar" dans le "gestionnaire Office", et là c'est beaucoup plus ennuyeux, il transforme tous les raccourcis non Office que j'ai pu y placer comme si je faisais la commande "Ctrl + P" pour imprimer !

Puis pas de raison que ça fonctionne bien sur d'autres forums PHP...

Tant pis, je continuerais comme ça...

Serge

boudoune

Re: Problème de changement de page suite avis de MAJ ???

Message par boudoune » 04 avr. 2009 20:47

Je n'ai pas ce problème et pour diverses raison j'utilise IE7, IE6, Mozilla, opéra, safari et même google chrome
Tous les navigateurs sont programmés pour vider automatiquement les cookies et les mots de passes
Je suis déconecté seulement si je reste sur le forum en étant inactif

Avatar de l’utilisateur
Subyland
Messages : 2576
Inscription : 25 janv. 2004 17:09
Localisation : Royaume-Uni
Contact :

Re: Problème de changement de page suite avis de MAJ ???

Message par Subyland » 04 avr. 2009 21:15

J'avoue aussi ne pas trop savoir ou regarder. :?: J'utilise Avant Browser et Firefox, les 2 sans problème.
Polar 620

Avatar de l’utilisateur
eden-speciale-540
Messages : 1302
Inscription : 22 mars 2009 23:25
Localisation : 2A - France

Re: Problème de changement de page suite avis de MAJ ???

Message par eden-speciale-540 » 04 avr. 2009 21:18

pour moi ce n'est pas lié au navigateur, j'avais effectué des tests avec firefox comme j'avais le défaut je suis passé avec opéra, comme j'ai eu pareil je suis passé sur une machine linux avec le même comportement : perte de session

je mettrai deux possibilités en avant:
- configuration d'un ou de paramètres pas idéaux dans l'APC de phpBB3 ( l'administration du forum, moins techniquement )
- conflit avec la version de PHP ( extrêmement rare mais si par exemple l'upload est impossible sur le serveur, ou si les sessions ne sont pas gérées ou mal gérées par le serveur on a ce type de phénomène - phénomène récurant chez certains hébergeurs )

J'enlève d'entrée la seconde possibilité car le site est hébergé par infomaniak que je connais très bien et qui ne pose pas ce type de conflit ( j'ai moi même des comptes chez eux avec phpbb et tout fonctionne bien )

donc la solution se veut technique, et j'ai pu remarquer plusieurs choses:
- le forum est placé dans un dossier /forums mais le cookies généré qui contient donc la session ne comprend par ce dossier ( ceci peut être une cause )
- le domaine placé dans le cookie dans l'APC de phpbb est peut être pas le bon www. ou pas ? /forums ou pas / ou pas ?
- dernier point et pas des moindre le forum est accessible autant par l'url lacaravane.com que par http://www.lacaravane.com ce qui n'est pas du tout la même chose !

par exemple je m'identifie par l'url lacaravane.com puis je reviens une heure après en saisissant http://www.lacaravane.com et hop j'ai perdu ma session ( normal puisque pour le navigateur nous ne sommes pas sur le même site ! www. était jugé comme un sous-domaine pour le navigateur )


Pour résumer trois points sont à contrôler dans au moins deux dans l'APC:
dans Réglages des cookies
- Domaine du cookie:: est il le bon ?
- Chemin du cookie:: est il le bon ?

troisième point à contrôler les réglages dans: Réglages du serveur et Réglages de la sécurité

dernier point il faudrait absolument faire en sorte que tout le monde accède ( y comprit les moteurs de recherches ) par http://www.lacaravane.com et exclusivement par cette url, ceci aurait plusieurs impacst dont celui des sessions mais et surtout d'éviter le duplicate content qui tend à dévaloriser le référencement d'un site internet ou d'un forum comme ici

ce post est un peu technique mais je pense qu'il est nécessaire

alors pourquoi certains ne sont pas touchés par ces déconnexions ?
probablement parce que le niveau de sécurité de leur machine le permet :(

efin, le temps de session est réglable dans l'apc tout simplement et souvent 7200 ne suffit pas :(
et la durée maximale pour envoyer des formulaires: à 7200 peut aussi déconnecter les utilisateurs si l'on ne poste pas assez rapidement un message

bref phpbb c'est plein de réglages qui ne restent pas toujours évidents en fonction de l'utilisation, de l'hébergeur et surtout si l'on place son forum dans un dossier ( mais ça fonctionne en toute logique sans défaut, reste à trouver ou )
Image
- Hobby 560 Cfe 2011 1750 kg avec ETS, Clim, Truma SER, JA, ...
- Mitsubishi Pajero 3.5 L V6 24S essence un peu modifié :) Caravanier au long cours
- ex Caravelair Eden Special 540 2009

Répondre

Revenir à « Le site La Caravane »